Plugin-Kompatibilität zu CMSimple_XH 1.7

Ein CMSimple Support Forum für deutsch sprechende Nutzer und Entwickler
cmb
Posts: 13703
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by cmb » Mon Feb 19, 2018 11:37 am

Berni wrote:
Sun Feb 11, 2018 8:02 pm
Wird es zum Plugin GXLink in absehbarer Zeit ein Update für cmsimple_xh 1.7 geben?
Hast du den aktuellen Stand einmal testweise ausprobiert? Es ist ja schon einiges geändert worden, und bevor das alles als Version 1.5.1 veröffentlich wird, wäre Feedback bezüglich potentieller Probleme nützlich. Zum Testen also einfach https://github.com/cmsimple-xh/gxlink/a ... master.zip herunter laden, entpacken, den Ordner gxlink-master/ in gxlink/ umbenennen, und wie üblich installieren.
Christoph M. Becker – Plugins for CMSimple_XH

Berni
Posts: 84
Joined: Wed Feb 12, 2014 4:38 pm
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by Berni » Mon Feb 19, 2018 3:52 pm

ja, soweit funktioniert es erst einmal wieder wie es soll - Danke

Hier für Dich zur Einsicht die Fehlermeldungen die der Debugger anzeigt:

Code: Select all

WARNING: extract() expects parameter 1 to be array, null given
Pfad .../cmsimple_xh/plugins/gxlink/admin.php:13
WARNING: extract() expects parameter 1 to be array, null given
Pfad .../cmsimple_xh/plugins/gxlink/admin.php:14
WARNING: extract() expects parameter 1 to be array, null given
Pfad .../cmsimple_xh/plugins/gxlink/admin.php:15
WARNING: extract() expects parameter 1 to be array, null given
Pfad .../cmsimple_xh/plugins/gxlink/admin.php:16
WARNING: extract() expects parameter 1 to be array, null given
Pfad .../cmsimple_xh/plugins/gxlink/admin.php:17

cmb
Posts: 13703
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by cmb » Mon Feb 19, 2018 4:23 pm

Berni wrote:
Mon Feb 19, 2018 3:52 pm
ja, soweit funktioniert es erst einmal wieder wie es soll - Danke
Prima! Ich spreche mich dann zeitnah mit Gerd wegen der 1.5.1 ab.
Berni wrote:
Mon Feb 19, 2018 3:52 pm
Hier für Dich zur Einsicht die Fehlermeldungen die der Debugger anzeigt:

Code: Select all

WARNING: extract() expects parameter 1 to be array, null given
Pfad .../cmsimple_xh/plugins/gxlink/admin.php:13
WARNING: extract() expects parameter 1 to be array, null given
Pfad .../cmsimple_xh/plugins/gxlink/admin.php:14
WARNING: extract() expects parameter 1 to be array, null given
Pfad .../cmsimple_xh/plugins/gxlink/admin.php:15
WARNING: extract() expects parameter 1 to be array, null given
Pfad .../cmsimple_xh/plugins/gxlink/admin.php:16
WARNING: extract() expects parameter 1 to be array, null given
Pfad .../cmsimple_xh/plugins/gxlink/admin.php:17
Das dürfte aber wohl Version 1.5 oder älter betreffen. Der gesamte extract() Code wurde im aktuellen master bereits entfernt.
Christoph M. Becker – Plugins for CMSimple_XH

lck
Posts: 2322
Joined: Wed Mar 23, 2011 11:43 am
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by lck » Wed Feb 21, 2018 7:17 pm

lck wrote:
Tue Nov 14, 2017 8:21 pm
OnePage_XH Version: 1.0beta2
System: Xampp mit PHP-Version 7.1.1 und CMSimple_XH 1.7.1

Ein Problem scheint noch zu sein:
Debug-Mode wrote:NOTICE: Undefined index: show_heading
D:\xampp\htdocs\cmsimplexh171\plugins\onepage\classes\Controller.php:286
Quick-Fix siehe https://github.com/cmb69/onepage_xh/issues/33
„Bevor du den Pfeil der Wahrheit abschießt, tauche die Spitze in Honig!“   👉 Ludwig's XH-Templates for MultiPage & OnePage

cmss
Posts: 209
Joined: Mon Jan 02, 2017 6:15 pm

Pdeditor Funktionalität

Post by cmss » Sun Jul 07, 2019 12:47 pm

Ich habe eine Frage zur Funktion des PDeditor :
Gehe ich auf Pdeditor – Pagedata 'linked_to_menu' oder 'published', so sehe ich 0- und 1-en bzw. 1-en und leere Felder. Das Menu funktioniert aber. Welche Auswirkungen haben hier Änderungen ?
Ich habe manchmal unerklärliche temporäre Seitenabstürze gehabt, die nach Ausfüllen oft wieder verschwanden - ich hatte vorher aber nichts geändert.

Hartmut
Posts: 539
Joined: Sat Nov 05, 2011 6:13 pm
Location: Butzbach, Deutschland
Contact:

Plugin-Kompatibilität zu CMSimple_XH 1.7 / PHP ≥ 7.2

Post by Hartmut » Thu May 14, 2020 11:06 am

Hallo,
ich bereite gerade eine Ergänzung der gut frequentierten Plugin Dokumentation vor und der Schwerpunkt liegt dabei auf der Plugin Kompabilität bzgl. den aktuellen PHP Versionen 7.2, 7.3 und 7.4.
Um mich bei dieser Recherche (etwas) zu entlasten würde ich mich über eure Unterstützung freuen, welches Plugin (mit welcher Version) ihr in welcher CMSimple_XH Version und PHP Version einsetzt und bei welchen Versionen habt ihr Probleme festgestellt habt.

In der CMSimple_XH Installation kann dies am einfachsten im Adminmenü unter "Einstellungen" => "Info" ("Settings" => "Info") in den folgenden Rubriken ermittelt werden:
• Installierte CMSimple Version
• Installierte Plugins
• PHP-Version

Eine Standardinstallation von CMSimple_XH 1.7.2 mit aktualisierten Plugins enthält ...
• Fa 1.2
• Filebrowser for CMSimple_XH 1.7.2
• Hi_updatecheck 1.4
• Jquery 1.6.4
• Meta_tags for CMSimple_XH 1.7.2
• Pagemanager 3.3
• Page_params for CMSimple_XH 1.7.2
• Tinymce4
und müssen nicht unbedingt aufgelistet werden

Falls in der Dokumentation einzelne Plugins fehlen, bzw. nicht mit der aktuellen Pluginversion aufgelistet sind, können mir die auch gern mitgeteilt werden.

Viele Grüße
Hartmut

Michael_G
Posts: 106
Joined: Thu Feb 18, 2016 11:01 pm
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by Michael_G » Tue May 26, 2020 6:24 pm

Hallo Hartmut,

sehr gerne helfe ich dabei aktiv mit:

Das sind meine Kandidaten, welche seit ihrem Erscheinen bzw. mind. seit CMSimple 1.7.2 (je nachdem was eher da war) positiv unauffällig waren:

Installierte CMSimple-Version
* CMSimple_XH 1.7.2  Released: 2017-12-21
Installierte Plugins
* 0page 1.0.b1
* Advancedform 1.2
* Ckeditor 2.2.1
* Exchange 1.0
* Meta_tags_plus 1.3
* Morepagedata 1.2.2
* Moved 1.0beta4
* Page_params for CMSimple_XH 1.7.2
* Pfw 0.2.0
* Polyglott 1.0beta2
* Quoteoftheday 1.1.1
* Seocheck 1.1
* Sitemapper 3.0beta1
Webserver
* Apache
PHP-Version
* 7.2.22

BTW (manchmal für Fehlersuche von Vorteil, wenn's bei jemandem hakt):
Internet-Service-Provider: bisher 1&1 IONOS, inzwischen alles bei 1blu
Webbrowser: bisher Firefox Quantum (neueste V.) unter Windows 7 Pro, seit 18.05.2020 Safari 13.1 unter macOS 10.15.4
Rechner: MacBook Air 1,1/16/1 TB (2020)

Negativ auffällig war also kein Plugin, sondern nur die Website, auf der die Erweiterungen samt Status gepflegt werden, die ist mir schon lange negativ aufgefallen durch immer noch fehlende Verschlüsselung! :shock:

Für die Webdesigner/kleinen Agenturen/sonstige Webdienstleister unter uns Forenteilnehmern ist es das Gegenteil von Werbung, wenn die eigene Website noch immer ohne Verschlüsselung arbeitet. :x
Anständige ISPs bieten Let´s Encrypt für alle Domains. Deshalb auch mein Wechsel weg von IONOS zu 1blu, weil das bei 10 Domains ins Geld geht.
Ciao
Michael

Let's Encrypt!

Hartmut
Posts: 539
Joined: Sat Nov 05, 2011 6:13 pm
Location: Butzbach, Deutschland
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by Hartmut » Wed May 27, 2020 4:18 pm

Michael_G wrote:
Tue May 26, 2020 6:24 pm
Hallo Hartmut,

sehr gerne helfe ich dabei aktiv mit:

Das sind meine Kandidaten, welche seit ihrem Erscheinen bzw. mind. seit CMSimple 1.7.2 (je nachdem was eher da war) positiv unauffällig waren:
...
Hallo Michael,

herzlichen Dank für deine Infos und ich habe sie auch schon in die Plugin Dokumentation eingepflegt. :D

Das Plugin 0page 1.0.b1 von Olaf kannte ich noch nicht und habe es in die Dokumentation aufgenommen. :?

Viele Grüße
Hartmut

7sleeper
Posts: 21
Joined: Fri Sep 24, 2010 12:11 pm

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by 7sleeper » Fri Apr 23, 2021 1:06 pm

Hartmut wrote:
Sun Nov 19, 2017 8:05 pm
Test Plugin hi_simplepdf Version: pr1.2

Getestet lokal unter
Xampp
PHP-Version 7.1.1
CMSimple_XH 1.7.1
Template fhs-simple
  • Plugin jm_iframe im Admin-Menü sichtbar? => Ja
  • Die Plugin Konfiguration ist nach Änderungen speicherbar.
  • Die Plugin Aufrufe erzeugen beim Anklicken einen "whitescreen" mit folgenden xampp-Fehlermeldungen:
    [19-Nov-2017 19:55:39 Europe/Berlin] PHP Fatal error: Uncaught DOMPDF_Exception: No block-level parent found. Not good. in C:\xampp\htdocs\plugins\hi_simplepdf\dompdf\include\inline_positioner.cls.php:37
    Stack trace:
    #0 C:\xampp\htdocs\plugins\hi_simplepdf\dompdf\include\frame_decorator.cls.php(700): Inline_Positioner->position()
    #1 C:\xampp\htdocs\plugins\hi_simplepdf\dompdf\include\text_frame_reflower.cls.php(330): Frame_Decorator->position()
    #2 C:\xampp\htdocs\plugins\hi_simplepdf\dompdf\include\frame_decorator.cls.php(711): Text_Frame_Reflower->reflow(NULL)
    #3 C:\xampp\htdocs\plugins\hi_simplepdf\dompdf\include\page_frame_reflower.cls.php(123): Frame_Decorator->reflow()
    #4 C:\xampp\htdocs\plugins\hi_simplepdf\dompdf\include\frame_decorator.cls.php(711): Page_Frame_Reflower->reflow(NULL)
    #5 C:\xampp\htdocs\plugins\hi_simplepdf\dompdf\include\dompdf.cls.php(949): Frame_Decorator->reflow()
    #6 C:\xampp\htdocs\plugins\hi_simplepdf\index.php(209): DOMPDF->render()
    #7 C:\xampp\htdocs\plugins\hi_simplepdf\index.php(11): simplePdfRender()
    #8 C:\xampp\htdocs\plugins\ in C:\xampp\htdocs\plugins\hi_simplepdf\dompdf\include\inline_positioner.cls.php on line 37
Ergebnis:
CMSimple_XH 1.7 Kompatibilität: Ja (mit CMSimple_XH 1.7.0 und PHP 5.6 erfolgreich getestet.)
PHP 7.0: ?? (nicht getestet)
PHP 7.1: Nein (siehe xampp-Fehlermeldungen)
Ist zwar schon lange her aber da ich simplepdf nutze und mir dieser Fehler jetzt auch unverhofft präsentiert wurde hier eine Möglichkeit ihn zu beheben (zumind. hat das bei mir geholfen):

die Datei dompdf/dompdf_config.inc.php bearbeiten und in Zeile 322 ändern

Code: Select all

def("DOMPDF_ENABLE_HTML5PARSER", false);
in

Code: Select all

def("DOMPDF_ENABLE_HTML5PARSER", true);
damit läuft es unter php 7.2

cmb
Posts: 13703
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by cmb » Fri Apr 23, 2021 8:41 pm

Danke! Das sollte vielleicht grundsätzlich im Plugin geändert werden, da HTML5 (hoffentlich) schon längst von allen Websites genutzt wird.
Christoph M. Becker – Plugins for CMSimple_XH

Post Reply