php problem

Questions about how to install and problems installing - please read the documentation first!
Post Reply
tazman69
Posts: 7
Joined: Mon Nov 23, 2009 3:35 pm

php problem

Post by tazman69 » Mon Nov 23, 2009 6:37 pm

Hi,
I am using wampserver with php 5.3.0 on my laptop.
And i have these errors:

Deprecated: Function eregi() is deprecated in C:\wamp\www\CMSimple 3.2 SE\cmsimple\cms.php on line 44

Notice: Undefined index: sefile in C:\wamp\www\CMSimple 3.2 SE\cmsimple\cms.php on line 62

Deprecated: Function eregi() is deprecated in C:\wamp\www\CMSimple 3.2 SE\cmsimple\functions.php on line 11

Deprecated: Assigning the return value of new by reference is deprecated in C:\wamp\www\CMSimple 3.2 SE\bbclone\lib\io.php on line 151

Can someone help me? :oops:

CMSimple-Styles.com
Posts: 342
Joined: Thu Jun 26, 2008 8:19 pm
Location: Germany
Contact:

Re: php problem

Post by CMSimple-Styles.com » Mon Nov 23, 2009 11:19 pm

I know of this problem and i am working on it! New version will be out soon!

Holger
Site Admin
Posts: 3212
Joined: Mon May 19, 2008 7:10 pm
Location: Hessen, Germany
Contact:

Re: php problem

Post by Holger » Tue Nov 24, 2009 8:02 am

Since all these are warnings until now, isn't it enough for the moment to to turn off error_reporting with two lines in top of cms.php?

Code: Select all

error_reporting(0);
ini_set('display_errors', 0); 
Of course the E_DEPRECATED warnings should be fixed ASAP in the code.
Bit IMO error_reporting should be off anyway on production systems.


Holger

johnjdoe
Posts: 571
Joined: Tue May 20, 2008 6:32 am

Re: php problem

Post by johnjdoe » Tue Nov 24, 2009 8:13 am

tazman69 wrote:Hi,
I am using wampserver with php 5.3.0 on my laptop.
And i have these errors:
Deprecated: Function eregi() is deprecated in C:\wamp\www\CMSimple 3.2 SE\cmsimple\cms.php on line 44
Or you could try CMSimple_XH. The latest RC should contain a solution for that.

mediatormedia
Posts: 1
Joined: Thu Dec 31, 2009 6:50 pm

Re: php problem

Post by mediatormedia » Thu Dec 31, 2009 7:57 pm

Any new developments on the DEPRECATED issue?
Thanks!

Rob

johnjdoe
Posts: 571
Joined: Tue May 20, 2008 6:32 am

Re: php problem

Post by johnjdoe » Sat Jan 02, 2010 4:24 pm

mediatormedia wrote:Any new developments on the DEPRECATED issue?
CMSimple_XH 1.0 ...

reduli
Posts: 1
Joined: Mon Jun 20, 2011 10:07 am

Re: php problem

Post by reduli » Mon Jun 20, 2011 10:11 am

In cms.php, line 44

replace:

if (eregi('cms.php',sv('PHP_SELF')))die('Access Denied');

by:

if (preg_match('/cms.php/',sv('PHP_SELF')))die('Access Denied');

jimsohan
Posts: 1
Joined: Tue Jan 24, 2012 8:17 am

Re: php problem

Post by jimsohan » Tue Jan 24, 2012 12:56 pm

Can anyone give some tips.We all are suffering from these problem.

mrleejohn
Posts: 33
Joined: Mon Dec 26, 2011 1:54 pm

Re: php problem

Post by mrleejohn » Mon Mar 12, 2012 8:18 am

These messages about 'eregi' probably are being caused by using an newer version of php on your webserver. Php5.3 has a lot of new options in the security area. And because of that often php errors occur.

I think that you have basically 2 options....

1. Replace in your cmsimple cms-files the option eregi by pregmatch (see earlier posting by Reduli). I did this too in early version of cmsimple. Search in every php-file of cmsimple for the word eregi an replace it by the pregmatch variant. You have to do this very precisely to avoid errors.
2. Use a newer version of Cmsimple. For example Cmsimpel XH1.5

Post Reply