CMSimple_XH 1.7.4 – Requirements Check gives a warning

Questions about how to install and problems installing - please read the documentation first!
Post Reply
roze
Posts: 248
Joined: Tue Jun 03, 2008 7:13 am
Location: NL
Contact:

CMSimple_XH 1.7.4 – Requirements Check gives a warning

Post by roze » Thu Mar 04, 2021 5:37 pm

I have a CMSimple_XH website on my Synology NAS for personal use.

I want to make the update from CMSimple_XH 1.7.3 to CMSimple_XH 1.7.4


I make a CMSimple_XH 1.7.4 – Requirements Check
Hmm, there appear to be minor issues!
CMSimple_XH 1.7.4 may not run smoothly on this server with the current PHP configuration!
The warning is:
Checking that session.use_only_cookies is off – warn
What do I have to do?
Rob Zeijen,

Valkenswaard (NL)

olape
Posts: 1829
Joined: Fri Mar 13, 2015 8:47 am
Contact:

Re: CMSimple_XH 1.7.4 – Requirements Check gives a warning

Post by olape » Fri Mar 05, 2021 6:47 am

I don't want to get too far ahead of myself. @cmb --> But is it possible that there is an error in the check here?

Code: Select all

$checks['session.use_only_cookies is off'] = ini_get('session.use_only_cookies') ? 'okay' : 'warn';
The statement is, check that session.use_only_cookies is off. But it checks if session.use_only_cookies is okay, so 1.

I think the check is correct, only the statement is wrong. It should be, in my opinion session.use_only_cookies is on.

--> In the PHP ini session.use_only_cookies should be set to 1

cmb
Posts: 13768
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: CMSimple_XH 1.7.4 – Requirements Check gives a warning

Post by cmb » Fri Mar 05, 2021 10:11 pm

olape wrote:
Fri Mar 05, 2021 6:47 am
I think the check is correct, only the statement is wrong. It should be, in my opinion session.use_only_cookies is on.
Indeed, thanks! Fixed that right away.

@roze: if you're using that on a NAT, I suppose the CMSimple_XH installation is not available outside your LAN (i.e. no foreign visitors can visit). In that case, you can just ignore that warning. Or do as Olaf suggested:
olape wrote:
Fri Mar 05, 2021 6:47 am
--> In the PHP ini session.use_only_cookies should be set to 1
After changing that, you need to restart your Webserver.
Christoph M. Becker – Plugins for CMSimple_XH

roze
Posts: 248
Joined: Tue Jun 03, 2008 7:13 am
Location: NL
Contact:

Re: CMSimple_XH 1.7.4 – Requirements Check gives a warning

Post by roze » Mon Mar 08, 2021 11:43 am

All Thanks.

I'll make a back-up and then perform the update.

I use this website on m NAS only @home.
Rob Zeijen,

Valkenswaard (NL)

roze
Posts: 248
Joined: Tue Jun 03, 2008 7:13 am
Location: NL
Contact:

Re: CMSimple_XH 1.7.4 – Requirements Check gives a warning

Post by roze » Mon Mar 08, 2021 12:55 pm

the update works fine on the Synology NAS.
Rob Zeijen,

Valkenswaard (NL)

Post Reply