Can't create directory

Questions about how to install and problems installing - please read the documentation first!
marius
Posts: 22
Joined: Sun Sep 26, 2010 7:51 am

Re: Can't create directory

Post by marius » Wed May 18, 2011 10:41 am

Holger thanks for your answer.
I just checked both folders:
images and downloads
In both there is no file called index.htm (no htm there @ all).
Images just contains image/flags (sub folder)
and in the image folder there are only jpg and gif files
The download folder contains a mix off zip and pdf files

I checked the server settings with my hosting provider.
Save mode is off
and there is a check box for register global activated, I checked that to be on.
I tried both options though, so save mode has been on and register global has been off.
Nothing seems to be the trick.

The entire site has been copied to another domain, there it seems to work just fine so there must be something with the server settings.
My domain provider is one of the biggest in the Netherlands so I don't think they have options missing that should be there..

This is starting to do my head in now.. :|
next try is erasing the entire site from the hosting server and start all over with a clean install (no templates, plug-ins or what ever).

spotburst
Posts: 6
Joined: Fri Jul 01, 2011 2:31 pm

Re: Can't create directory

Post by spotburst » Mon Jul 04, 2011 12:04 pm

No solution I afraid but merely confirming that I've hit the same 'wall'.

My FCKeditor process for managing images (images tab) is responding in the same way.
Unable to create subdir (although all chmod 777)
I was able to upload a file to ./images but my FCKeditor 'insert image' was not able to browse Images-root - no response.

I know that the uploaded image file arrived OK in this directory, however when I try to insert an image I'm presented with the image properties page (complete with the "Lorem ipsum dolor" text but it's browse server button only shows the panel 'create subfolder' or 'images root'. Browse (local PC) & upload work but after closing this panel down (back to 'image properties') I can ONLY insert an image if I specify the URL manually (./images/xyz.jpg).

So it appears that directory permissions are OK - for both image upload and by typing URL, but not using FCKeditor process for browsing or creating sub-dirs.

I'll keep eye out here for any possible solution/assist.

cmb
Posts: 13342
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Can't create directory

Post by cmb » Mon Jul 04, 2011 12:21 pm

Hello spotburst,

I've got currently no time to investigate further (it's a very long thread), but it seems to me that the problem is the FCKeditor file browser. Which version of CMSimple are you using?

Perhaps a workaround could be the new hi_kcfinder plugin, if your installation fulfills it's requirements.

Christoph
Christoph M. Becker – Plugins for CMSimple_XH

spotburst
Posts: 6
Joined: Fri Jul 01, 2011 2:31 pm

Re: Can't create directory

Post by spotburst » Mon Jul 04, 2011 12:37 pm

Hi cmb,

I'll take a look at your suggestion later today, and I'll report back.

FYI : my ver: CMSimple_XH_1.4.1

Just out of interest I fully opened up my structure with a chmod -R 777 - to see if it would unblock anything permissions-wise (I'll reinstall some time later anyway).

chmod -R *
chmod: changing permissions of `content/20110701_192122_content.htm': Operation not permitted
chmod: changing permissions of `content/20110704_121557_pagedata.php': Operation not permitted
chmod: changing permissions of `content/20110701_144845_content.htm': Operation not permitted
chmod: changing permissions of `content/20110701_160118_content.htm': Operation not permitted
chmod: changing permissions of `content/20110704_121557_content.htm': Operation not permitted
chmod: changing permissions of `content/20110704_091903_pagedata.php': Operation not permitted
chmod: changing permissions of `content/20110701_160118_pagedata.php': Operation not permitted
chmod: changing permissions of `content/20110701_144845_pagedata.php': Operation not permitted
chmod: changing permissions of `content/20110701_192122_pagedata.php': Operation not permitted
chmod: changing permissions of `content/20110704_091903_content.htm': Operation not permitted
chmod: changing permissions of `images/AVRDragon.jpg': Operation not permitted
jh161% chmod: changing permissions of `content/20110701_192122_content.htm': Operation not permitted
Unmatched `.
jh162% chmod: changing permissions of `content/20110704_121557_pagedata.php': Operation not permitted
Unmatched `.
jh163% chmod: changing permissions of `content/20110701_144845_content.htm': Operation not permitted
Unmatched `.
jh164% chmod: changing permissions of `content/20110701_160118_content.htm': Operation not permitted
Unmatched `.
jh165% chmod: changing permissions of `content/20110704_121557_content.htm': Operation not permitted
chmod: changing permissions of `content/20110701_160118_pagedata.php': Operation not permitted
Unmatched `.
jh166% chmod: changing permissions of `content/20110701_144845_pagedata.php': Operation not permitted
chmod: changing permissions of `content/20110701_192122_pagedata.php': Operation not permitted
chmod: changing permissions of `content/20110704_091903_pagedata.php': Operation not permitted
Unmatched `.
chmod: changing permissions of `content/20110704_091903_content.htm': Operation not permitted
chmod: changing permissions of `images/AVRDragon.jpg': Operation not permitted

I noticed that :
-rw-r--r-- 1 apache 48 64457 Jul 1 14:58 AVRDragon.jpg
drwxrwxrwx 2 jh1 ad_staff 4096 Jun 30 16:09 flags

i.e. my FCKeditor uploaded image appears owned by apache/48 !
ditto all the other 'not permitted's

Any help appreciated.

spotburst
Posts: 6
Joined: Fri Jul 01, 2011 2:31 pm

Re: Can't create directory

Post by spotburst » Mon Jul 04, 2011 12:39 pm

.....sorry about the unmatched ' there.
They're superfluous. My finger touble.

cmb
Posts: 13342
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Can't create directory

Post by cmb » Mon Jul 04, 2011 1:15 pm

Hello spotburst,

I'm far from being an expert in systems administration. So I will not speculate about user authentifiction etc.

IMO it will be best, if you try a fresh installation. That should work.

Christoph

BTW: please format larger amounts of copy&paste information as "code".
Christoph M. Becker – Plugins for CMSimple_XH

spotburst
Posts: 6
Joined: Fri Jul 01, 2011 2:31 pm

Re: Can't create directory

Post by spotburst » Mon Jul 04, 2011 2:05 pm

A fresh install I have indeed performed.
Along with a chmod -R 777.

If I then perform a page edit of Welcome to 'CMSimple_XH' with a click of the 'insert image/edit' icon I obtain the 'image properties' panel ("Lorem ipsum dolor...")

If I perform 'browse server' I get the familiar Resource Browser::FCKeditor4CMSimple screen.
Images-Root is not browsable (inactive on a click other than faint dotted-box upon selection).
I would expect at this point to at least be able to navigate/see to the preinstalled 'flags' subdir.

Clicking on create Subfiolder results in being prompted for 'Type the name of the new folder', however, after supplying a name a click on 'OK' results in
"You have no permissions to create the folder"

[ external image ]

All this is with all files/directories set to 777 - wide open.

I'll try the hi_kcfinder work around that has been suggested.

Many thanks,
Spotburst

cmb
Posts: 13342
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Can't create directory

Post by cmb » Mon Jul 04, 2011 2:34 pm

Hello spotburst,
spotburst wrote: Along with a chmod -R 777.
In the root dir and with no error messages, I assume.

And I assume you're using FCKeditor distributed along with CMSimple_XH 1.4.1.

Have you checked file ownership and permissions again? IMHO there must someone have changed the access rights afterwards.

Christoph
Christoph M. Becker – Plugins for CMSimple_XH

Holger
Site Admin
Posts: 3212
Joined: Mon May 19, 2008 7:10 pm
Location: Hessen, Germany
Contact:

Re: Can't create directory

Post by Holger » Mon Jul 04, 2011 5:33 pm

cmb wrote:Have you checked file ownership
That's the right way IMO... The old User / Owner problem.
Is PHP running on cgi or as a Apache-modul?

KR
Holger

spotburst
Posts: 6
Joined: Fri Jul 01, 2011 2:31 pm

Re: Can't create directory

Post by spotburst » Mon Jul 04, 2011 6:05 pm

Is PHP running on cgi or as a Apache-modul?
Unles there's a simple command line to run, I'm not sure. Sysadmin is away for a week so I may just wait until he's back.

I noticed something else though:
I tired the hi_kcfinder plug-in - again everything set to 777.
From within CMSimple_XH I'm able to select the finder as a plug-in & configure and save the config file.
But in a page edit if I try to insert an image I get an error:
Warning: mkdir(): No such file or directory in /home/jh1/public_html/plugins/hi_kcfinder/kcfinder/core/uploader.php on line 169
It looks suspiciously like the mkdir is being blocked(?)

Again, I think I need to ask my sysadmin about php level security (he did grumble a bit about 'known exploits' before he removed a certain degree of security for me to try this CMS!)

I'll report back next week I guess.

Post Reply