after installation cmsimple 4.0.3

Questions about how to install and problems installing - please read the documentation first!
roze
Posts: 230
Joined: Tue Jun 03, 2008 7:13 am
Location: NL
Contact:

Re: after installation cmsimple 4.0.3

Post by roze » Tue Dec 11, 2012 7:06 am

The answer of my provider:
De foutmelding welke u krijgt wordt veroorzaakt doordat CMSimple op een verkeerde manier de url van uw website uitleest.

De oorzaak hiervan zal gezocht mogen worden in de code van CMSimple. Ik heb hier zojuist voor u naar gekeken en kan u enkel verwijzen naar de leverancier van de software of onze webdesign afdeling.

Code: Select all

The cause is that CMSIMPLE reads the URL the wrong way. The cause is in the code of CMsimple. I just looked to it and I only can direct you to the manufacturer of the software or our designdepartment
Rob Zeijen,

Valkenswaard (NL)

Gert
Posts: 3075
Joined: Fri May 30, 2008 4:53 pm
Location: Berlin
Contact:

Re: after installation cmsimple 4.0.3

Post by Gert » Tue Dec 11, 2012 9:32 am

Hi Rob,

that's nonsense, but typically for a hoster ...

Please make a servertest.php with following content:

Code: Select all

<!DOCTYPE html>
<html>
<head>
<meta http-equiv="content-type" content="text/html;charset=utf-8">
<title>Server Test</title>

<body>
<!-- äöü -->
<h1>Server Test</h1>

<table style="width: 300px;">
<?php 
echo '<tr style="height: 30px;"><td><b>REQUEST_URI: </b></td><td>' . $_SERVER['REQUEST_URI'] . '</td></tr>';
echo '<tr style="height: 30px;"><td><b>SCRIPT_NAME: </b></td><td>' . $_SERVER['SCRIPT_NAME'] . '</td></tr>';
echo '<tr style="height: 30px;"><td><b>PHP_SELF: </b></td><td>' . $_SERVER['PHP_SELF'] . '</td></tr>';
?>
</table>
</body>
</html>
... and put it to the folder /haptonomiedommelen/

Then call the servertest.php with your browser, the output should be:

REQUEST_URI: /servertest.php
SCRIPT_NAME: /servertest.php
PHP_SELF: /servertest.php

Please tell me, when you have uploaded the servertest.php, so that I can have a look,

Gert
Gert Ebersbach | CMSimple | Templates - Plugins - Services

roze
Posts: 230
Joined: Tue Jun 03, 2008 7:13 am
Location: NL
Contact:

Re: after installation cmsimple 4.0.3

Post by roze » Tue Dec 11, 2012 10:02 am

Gert,

The servertest gives:

Server Test
REQUEST_URI: /servertest.php
SCRIPT_NAME: /haptonomiedommelen/servertest.php
PHP_SELF: /haptonomiedommelen/servertest.php
Rob Zeijen,

Valkenswaard (NL)

Gert
Posts: 3075
Joined: Fri May 30, 2008 4:53 pm
Location: Berlin
Contact:

Re: after installation cmsimple 4.0.3

Post by Gert » Tue Dec 11, 2012 10:07 am

roze wrote:The servertest gives:

Server Test
REQUEST_URI: /servertest.php
SCRIPT_NAME: /haptonomiedommelen/servertest.php
PHP_SELF: /haptonomiedommelen/servertest.php
Now you can see: It's independent of CMSimple, the values of SCRIPT_NAME and PHP_SELF are wrong.

Now you can contact your hoster again ;)

(but delete CMSimple from the folder /haptonomiedommelen/ at first, so that there is no relation to CMSimple)

Gert
Gert Ebersbach | CMSimple | Templates - Plugins - Services

cmb
Posts: 13342
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: after installation cmsimple 4.0.3

Post by cmb » Tue Dec 11, 2012 11:11 am

Hi Gert,
Gert wrote:Now you can see: It's independent of CMSimple, the values of SCRIPT_NAME and PHP_SELF are wrong.
Are they really wrong in the sense they are specified, or are they wrong only in the sense that you/we expect them to be the same as REQUEST_URI in this case? :|

We should consult the CGI 1.1 specification with regard to SCRIPT_NAME.

Christoph
Christoph M. Becker – Plugins for CMSimple_XH

Gert
Posts: 3075
Joined: Fri May 30, 2008 4:53 pm
Location: Berlin
Contact:

Re: after installation cmsimple 4.0.3

Post by Gert » Tue Dec 11, 2012 11:25 am

Hello,

that should be normal:

http://www.kstb.de/servertest.php/irgen ... ery_string

kstb.de is moved permanently to a subdirectory of the server account:

http://www.ge-webdesign.de/kstb/servert ... ery_string

THE DOMAIN should be the home of all files and scripts of a website,

Gert
Gert Ebersbach | CMSimple | Templates - Plugins - Services

roze
Posts: 230
Joined: Tue Jun 03, 2008 7:13 am
Location: NL
Contact:

Re: after installation cmsimple 4.0.3

Post by roze » Tue Dec 11, 2012 11:42 am

Gert wrote: Now you can contact your hoster again ;)
after deleting CMsimple I've send a mail
Rob Zeijen,

Valkenswaard (NL)

cmb
Posts: 13342
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: after installation cmsimple 4.0.3

Post by cmb » Tue Dec 11, 2012 12:00 pm

Gert wrote:kstb.de is moved permanently to a subdirectory of the server account:
But in Rob's case there is no "external" redirect at all (check the headers). All seems to be done with an an "internal" redirect (a mod_rewrite rule without R flag).
Christoph M. Becker – Plugins for CMSimple_XH

Holger
Site Admin
Posts: 3212
Joined: Mon May 19, 2008 7:10 pm
Location: Hessen, Germany
Contact:

Re: after installation cmsimple 4.0.3

Post by Holger » Tue Dec 11, 2012 12:07 pm

Hi,

just a little OT - remark:

:shock:

Code: Select all

echo '<tr style="height: 30px;"><td><b>PHP_SELF: </b></td><td>' . $_SERVER['PHP_SELF'] . '</td></tr>'; 

http://www.kstb.de/servertest.php/irgendwas/

Always sanitize User-Input!

;)

Holger

Gert
Posts: 3075
Joined: Fri May 30, 2008 4:53 pm
Location: Berlin
Contact:

Re: after installation cmsimple 4.0.3

Post by Gert » Tue Dec 11, 2012 12:27 pm

Holger wrote:Always sanitize User-Input!
Hi Rob,

I will send you the new servertest.php by PM,

Gert

PS: A further reason to use $_SERVER['SCRIPT_NAME'] ...
Gert Ebersbach | CMSimple | Templates - Plugins - Services

Post Reply