after installation cmsimple 4.0.3

Questions about how to install and problems installing - please read the documentation first!
roze
Posts: 230
Joined: Tue Jun 03, 2008 7:13 am
Location: NL
Contact:

Re: after installation cmsimple 4.0.3

Post by roze » Thu Dec 13, 2012 3:33 pm

Making different web-spaces is a expensive solution :(

So I put the two line in de CMS like this:

Code: Select all

// CMSimpleSubsites: prepare CMSIMPLE_ROOT

if (preg_match('/cms.php/i', $_SERVER['SCRIPT_NAME']))
    die('Access Denied');
	
define('CMSIMPLE_ROOT', $pth['folder']['base']);
define('CMSIMPLE_BASE', $pth['folder']['base']); 


$cmsimpleRootVar = $_SERVER['SCRIPT_NAME'];
$cmsimpleRootArray = explode('/', $cmsimpleRootVar);
Unfortunaly: no result
Rob Zeijen,

Valkenswaard (NL)

Gert
Posts: 3075
Joined: Fri May 30, 2008 4:53 pm
Location: Berlin
Contact:

Re: after installation cmsimple 4.0.3

Post by Gert » Thu Dec 13, 2012 3:58 pm

Hello Rob,

have you REPLACED the old definitions? Search for:

Code: Select all

define('CMSIMPLE_ROOT', $cmsimpleRootVarNew);
define('CMSIMPLE_BASE', $pth['folder']['base']); 
and replace with:

Code: Select all

define('CMSIMPLE_ROOT', $pth['folder']['base']);
define('CMSIMPLE_BASE', $pth['folder']['base']);  
In the original cms.php it is in line 59-60,

Gert
Gert Ebersbach | CMSimple | Templates - Plugins - Services

cmb
Posts: 13342
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: after installation cmsimple 4.0.3

Post by cmb » Thu Dec 13, 2012 4:12 pm

Hi Rob,

it might work, if you replace all 9 occurences of "CMSIMPLE_ROOT" with "/" in cmsimple/login.php. And restore the old definition of CMSIMPLE_ROOT in cmsimple/cms.php.

Christoph
Christoph M. Becker – Plugins for CMSimple_XH

Gert
Posts: 3075
Joined: Fri May 30, 2008 4:53 pm
Location: Berlin
Contact:

Re: after installation cmsimple 4.0.3

Post by Gert » Thu Dec 13, 2012 4:31 pm

Hi Rob,

it's better to make ONE change in cms.php than 9 changes in the login.php, so you should try this at first.

And don't forget to clear the browser cache and delete the cookies,

Gert
Gert Ebersbach | CMSimple | Templates - Plugins - Services

roze
Posts: 230
Joined: Tue Jun 03, 2008 7:13 am
Location: NL
Contact:

Re: after installation cmsimple 4.0.3

Post by roze » Thu Dec 13, 2012 4:48 pm

Gert,

In the CMs.php I find 3 times CMSSIMPLE_Root

Code: Select all

	Line 29: // CMSimpleSubsites: prepare CMSIMPLE_ROOT
	Line 59: define('CMSIMPLE_ROOT', $pth['folder']['base']);
	Line 117: $subsite_folder = str_replace(CMSIMPLE_ROOT, '', $_SERVER['SCRIPT_NAME']);
What is the change you want me to try and make?


And the earlier change:

Code: Select all

define('CMSIMPLE_ROOT', $pth['folder']['base']);
define('CMSIMPLE_BASE', $pth['folder']['base']); 
Ddo i have to leave that this way?
Rob Zeijen,

Valkenswaard (NL)

Gert
Posts: 3075
Joined: Fri May 30, 2008 4:53 pm
Location: Berlin
Contact:

Re: after installation cmsimple 4.0.3

Post by Gert » Thu Dec 13, 2012 5:05 pm

Hi Rob,

change line 59,

Gert

PS: maybe, that subsites does not work after that change, because CMSIMPLE_ROOT is not right for line 117, but CMSIMPLE_ROOT is wrong anyway on your webserver.

Best choice: Change the provider :mrgreen:
Gert Ebersbach | CMSimple | Templates - Plugins - Services

roze
Posts: 230
Joined: Tue Jun 03, 2008 7:13 am
Location: NL
Contact:

Re: after installation cmsimple 4.0.3

Post by roze » Thu Dec 13, 2012 7:53 pm

Gert,

I changed the lines in CMS.php into:

59 define('/', $pth['folder']['base']);
60 define('CMSIMPLE_BASE', $pth['folder']['base']);

without result.
Rob Zeijen,

Valkenswaard (NL)

Gert
Posts: 3075
Joined: Fri May 30, 2008 4:53 pm
Location: Berlin
Contact:

Re: after installation cmsimple 4.0.3

Post by Gert » Thu Dec 13, 2012 8:11 pm

Code: Select all

59 define('CMSIMPLE_ROOT', $pth['folder']['base']);
60 define('CMSIMPLE_BASE', $pth['folder']['base']); 
Gert Ebersbach | CMSimple | Templates - Plugins - Services

roze
Posts: 230
Joined: Tue Jun 03, 2008 7:13 am
Location: NL
Contact:

Re: after installation cmsimple 4.0.3

Post by roze » Thu Dec 13, 2012 8:24 pm

So, the only change in my CMS.php now is

define('CMSIMPLE_ROOT', $pth['folder']['base']);
define('CMSIMPLE_BASE', $pth['folder']['base']);
Rob Zeijen,

Valkenswaard (NL)

Gert
Posts: 3075
Joined: Fri May 30, 2008 4:53 pm
Location: Berlin
Contact:

Re: after installation cmsimple 4.0.3

Post by Gert » Thu Dec 13, 2012 9:44 pm

And now?

If it don't work, try Christophs variant (login.php),

Gert
Gert Ebersbach | CMSimple | Templates - Plugins - Services

Post Reply