Unable to Save Updated Content in CMSimple Website

Questions about how to use the online - editors and suggestions how to improve them
Post Reply
zjpratt
Posts: 3
Joined: Tue Sep 18, 2012 7:47 pm

Unable to Save Updated Content in CMSimple Website

Post by zjpratt » Tue Sep 18, 2012 8:00 pm

It was working fine until I copied text from another program into my CMSimple website. Nothing happens when I attempt to save the changes that I have made. If I cut or delete the changes and then try to save it, nothing happens. I have tried logging out and then logging back in and then trying to delete the text again. The copied text cannot be deleted. Can someone help?

cmb
Posts: 13760
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Unable to Save Updated Content in CMSimple Website

Post by cmb » Tue Sep 18, 2012 8:15 pm

Hi,

which version of CMSimple do you use? Might be a problem with the respective editor (perhaps in combination with a particular browser).

If all else fails, you can edit content/content.htm with a text editor and delete the text there -- but keep a back-up of the file!

Christoph
Christoph M. Becker – Plugins for CMSimple_XH

zjpratt
Posts: 3
Joined: Tue Sep 18, 2012 7:47 pm

Re: Unable to Save Updated Content in CMSimple Website

Post by zjpratt » Tue Sep 18, 2012 9:00 pm

I believe I am using CMSimple 3.4.

cmb
Posts: 13760
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Unable to Save Updated Content in CMSimple Website

Post by cmb » Tue Sep 18, 2012 9:40 pm

So I guess you're using oEdit, the default editor of CMSimple <= 3.4. I can imagine (I haven't experienced that yet), that it has problems to remove some weird HTML pasted from another program. If you have some knowledge of HTML, you might try to delete the unwanted part in the "source code" mode. Otherwise you might use the demo of tinyMCE:
  • make a backup of content/content.htm
  • switch to the broken page
  • switch to the "source code" (i.e. HTML) mode
  • copy everything to the clipboard
  • go to the tinyMCE demo
  • delete the page
  • paste your page back in
  • mark everything
  • press the "clean messy code" toolbar button
  • copy everything to the clipboard
  • switch back to your page
  • overwrite the existing content with the content of the clipboard
  • save the page
This might work. If it doesn't work, or you don't feel confident to do it, please post a link to the broken page.

Christoph
Christoph M. Becker – Plugins for CMSimple_XH

zjpratt
Posts: 3
Joined: Tue Sep 18, 2012 7:47 pm

Re: Unable to Save Updated Content in CMSimple Website

Post by zjpratt » Wed Sep 19, 2012 1:04 am

I can't get it to work. The text I copied is from a website that I designed. If you have the time to look at it you will see the text that I pasted into the document is below the heading "Contact Us". There is something strange going on. For some reason, part of the code displays at the bottom, on the outside of the "Edit Content" box. You will see a "submit" button and two radio buttons. I don't know why they appear there. Here is the link http://cmsimple.zenapratt.me/?file=content . Hopefully, you can access it.

Thanks.

Torsten.Behrens
Posts: 522
Joined: Thu May 22, 2008 7:27 am
Location: Germany / Schleswig-Holstein
Contact:

Re: Unable to Save Updated Content in CMSimple Website

Post by Torsten.Behrens » Wed Sep 19, 2012 7:25 am

zjpratt wrote: Here is the link http://cmsimple.zenapratt.me/?file=content .
http://cmsimple.zenapratt.me/ -> see inside your default/template.htm and repair the added code.
Or overwrite it with the original template file.
Torsten Behrens
CMSimple Templates

cmb
Posts: 13760
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Unable to Save Updated Content in CMSimple Website

Post by cmb » Wed Sep 19, 2012 8:24 am

zjpratt wrote:Here is the link http://cmsimple.zenapratt.me/?file=content . Hopefully, you can access it.
No, I can't. That link only works when one is logged in to the system, because viewing the content file should only be allowed for authorized persons.

Unfortunately I can't access the "Contact Us" page, because there's no visible link in the menu and calling http://cmsimple.zenapratt.me/?Contact_Us replies with "Not found".
Torsten.Behrens wrote:see inside your default/template.htm and repair the added code
Indeed that's what could cause the trouble. The content of the style attribute of the <body> element should better go to templates/default/stylesheet.css. The remaining <body> should read:

Code: Select all

<body  <?php echo onload();?>>
The <?php echo onload();?> is important for proper functioning of the editor.
Christoph M. Becker – Plugins for CMSimple_XH

Post Reply